summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-11 19:49:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-11 19:49:27 +0100
commit63d4ef52ebad4157817d56ccbe974da8fff81929 (patch)
tree058d5a4bf953622d89d2d91d2c9054200bbe8cc2 /gnu/packages/linux.scm
parentf85ca6eda044c43bd5b9b54e756c02fd90c372f1 (diff)
downloadguix-patches-63d4ef52ebad4157817d56ccbe974da8fff81929.tar
guix-patches-63d4ef52ebad4157817d56ccbe974da8fff81929.tar.gz
gnu: Remove GCC < 7 workarounds.
* gnu/packages/emulators.scm (dolphin-emu)[native-inputs]: Remove GCC-7. [arguments]: Adjust accordingly. * gnu/packages/games.scm (openrct2): Likewise. * gnu/packages/linux.scm (make-linux-libre): Likewise. * gnu/packages/mpd.scm (mpd): Likewise. * gnu/packages/storage.scm (ceph): Likewise.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d7c242015e..e71c62900f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -308,10 +308,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("flex" ,flex)
("bison" ,bison)
- ;; Build with GCC-7 for full retpoline support.
- ;; FIXME: Remove this when our default compiler has retpoline support.
- ("gcc" ,gcc-7)
-
;; These are needed to compile the GCC plugins.
("gmp" ,gmp)
("mpfr" ,mpfr)
@@ -338,11 +334,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(substitute* (find-files "." "^Makefile(\\.include)?$")
(("/bin/pwd") "pwd"))
#t))
- (add-before 'configure 'work-around-gcc-7-include-path-issue
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
(replace 'configure
(lambda* (#:key inputs native-inputs target #:allow-other-keys)
;; Avoid introducing timestamps