summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-05 19:36:59 +0200
committerMark H Weaver <mhw@netris.org>2019-08-06 02:17:38 -0400
commit2426e2c94cdf9fcf28bba28b1e84b1aa5f652332 (patch)
treedcd24a1c810c823ac8a9da4c19df4ef17c9a7594 /gnu/packages/linux.scm
parent96681d4be101c771fafd4257aca471685119fedd (diff)
downloadguix-patches-2426e2c94cdf9fcf28bba28b1e84b1aa5f652332.tar
guix-patches-2426e2c94cdf9fcf28bba28b1e84b1aa5f652332.tar.gz
gnu: strace: Fix test failures on some systems.
* gnu/packages/patches/strace-ipc-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/linux.scm (strace)[source](patches): New field. [arguments]: Add 'regenerate-tests' phase. Co-Authored-By: Mark H Weaver <mhw@netris.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 44526e3786..9f20d2bace 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1408,6 +1408,9 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(method url-fetch)
(uri (string-append home-page "/files/" version
"/strace-" version ".tar.xz"))
+ ;; XXX Remove the 'regenerate-tests' phase below when
+ ;; "strace-ipc-tests.patch" is no longer applied.
+ (patches (search-patches "strace-ipc-tests.patch"))
(sha256
(base32
"1li49i75wrdw91hchyyd8spnzfcmxcfyfb5g9zbaza89aq4bq4ym"))))
@@ -1419,7 +1422,14 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(lambda _
(substitute* "strace.c"
(("/bin/sh") (which "sh")))
- #t)))
+ #t))
+ (add-before 'configure 'regenerate-tests
+ ;; XXX Remove this phase when "strace-ipc-tests.patch" is no longer
+ ;; applied in the 'source' field above. This phase is needed to
+ ;; regenerate many other files from tests/gen_tests.in, which is
+ ;; modified by the aforementioned patch.
+ (lambda _
+ (invoke "tests/gen_tests.sh"))))
;; Don't fail if the architecture doesn't support different personalities.
#:configure-flags '("--enable-mpers=check")
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32459>.