summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-09-20 14:59:20 -0500
committerLudovic Courtès <ludo@gnu.org>2016-09-28 23:01:49 +0200
commit411264c250cb6a6485851890f0d3ec5fb508dbfa (patch)
tree7af48ea701679f880aa73ff0d3b0919fbdd06eb3 /gnu/packages/linux.scm
parent789f09a073a7239aee2e551d52b5b5ea9f41bb90 (diff)
downloadguix-patches-411264c250cb6a6485851890f0d3ec5fb508dbfa.tar
guix-patches-411264c250cb6a6485851890f0d3ec5fb508dbfa.tar.gz
gnu: linux-pam: Allow compilation on GNU/Hurd.
* gnu/packages/patches/linux-pam-no-setfsuid.patch: New file. * gnu/packages/linux.scm (linux-pam)[source]: Use it. (linux-pam-1.2)[source]: Likewise. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 50568d2125..2069170440 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
+;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -414,7 +415,9 @@ It has been modified to remove all non-free binary blobs.")
"Linux-PAM-" version ".tar.bz2"))
(sha256
(base32
- "1fyi04d5nsh8ivd0rn2y0z83ylgc0licz7kifbb6xxi2ylgfs6i4"))))
+ "1fyi04d5nsh8ivd0rn2y0z83ylgc0licz7kifbb6xxi2ylgfs6i4"))
+ (patches (search-patches "linux-pam-no-setfsuid.patch"))))
+
(build-system gnu-build-system)
(native-inputs
`(("flex" ,flex)
@@ -455,8 +458,8 @@ at login. Local and dynamic reconfiguration are its key features.")
"Linux-PAM-" version ".tar.bz2"))
(sha256
(base32
- "1n9lnf9gjs72kbj1g354v1xhi2j27aqaah15vykh7cnkq08i4arl"))))))
-
+ "1n9lnf9gjs72kbj1g354v1xhi2j27aqaah15vykh7cnkq08i4arl"))
+ (patches (search-patches "linux-pam-no-setfsuid.patch"))))))
;;;