summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-21 01:07:17 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-21 01:14:51 +0200
commit9f8d6eb24a5f193683076e16ffb68da18a537140 (patch)
tree0f745b79798f323358aadb0c4aa9566e1c54cfed /gnu/packages/linux.scm
parent9a1bfe764859365b6726f168da95b88a2d22403b (diff)
downloadguix-patches-9f8d6eb24a5f193683076e16ffb68da18a537140.tar
guix-patches-9f8d6eb24a5f193683076e16ffb68da18a537140.tar.gz
gnu: unionfs-fuse-static: Remove 'unionfsctl' executable.
This avoids pulling in glibc & co. Fixes a regression introduced in 2f861edf5cf5118ad560737343312c9a5efe5b2f (the 'unionfsctl' executable did not exist in unionfs-fuse 0.26). * gnu/packages/linux.scm (unionfs-fuse/static)[arguments] <post-install>: Remove 'unionfsctl' binary.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 835ae06ca3..d133fbdedd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1568,7 +1568,12 @@ UnionFS-FUSE additionally supports copy-on-write.")
(exe (string-append out "/bin/unionfs")))
;; By default, 'unionfs' keeps references to
;; $glibc/share/locale and similar stuff. Remove them.
- (remove-store-references exe)))
+ (remove-store-references exe)
+
+ ;; 'unionfsctl' has references to glibc as well. Since
+ ;; we don't need it, remove it.
+ (delete-file (string-append out "/bin/unionfsctl"))
+ #t))
%standard-phases)))
(inputs `(("fuse" ,fuse-static)))))