summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-12-09 18:11:14 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-09 18:11:14 +0100
commitf80b4d2ce09b0b7770cbdf2f90704d41b0a168c5 (patch)
treeec47c7ee5d5579cfa00f13b5038ff3d8c87e4a48 /gnu/packages/linux.scm
parent13b5f44b475aa385d580f7e19b907210bc1d6d99 (diff)
parent2608e40988ba8cf51723fe0d21bdedf6b3997c9c (diff)
downloadguix-patches-f80b4d2ce09b0b7770cbdf2f90704d41b0a168c5.tar
guix-patches-f80b4d2ce09b0b7770cbdf2f90704d41b0a168c5.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm48
1 files changed, 7 insertions, 41 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fca86cf3f6..3c24987aae 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2563,55 +2563,21 @@ is flexible, efficient and uses a modular implementation.")
(define-public fuse-exfat
(package
(name "fuse-exfat")
- (version "1.1.0")
+ (version "1.2.5")
(source (origin
(method url-fetch)
- (uri "https://docs.google.com/uc?export=download&\
-id=0B7CLI-REKbE3VTdaa0EzTkhYdU0")
+ (uri (string-append
+ "https://github.com/relan/exfat/releases/download/v"
+ version "/" name "-" version ".tar.gz"))
(sha256
(base32
- "0glmgwrf0nv09am54i6s35ksbvrywrwc51w6q32mv5by8475530r"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "1i0sh0s6wnm4dqxli3drva871wgbbm57qjf592vnswna9hc6bvim"))))
(build-system gnu-build-system)
(native-inputs
- `(("scons" ,scons)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("fuse" ,fuse)))
- (arguments
- '(#:tests? #f ;no test suite
-
- ;; XXX: Factorize with 'exfat-utils'.
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'scons-propagate-environment
- (lambda _
- ;; Modify the SConstruct file to arrange for
- ;; environment variables to be propagated.
- (substitute* "SConstruct"
- (("^env = Environment\\(")
- "env = Environment(ENV=os.environ, "))))
- (replace 'build
- (lambda _
- (zero? (system* "scons"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (man8 (string-append out
- "/share/man/man8")))
- (mkdir-p bin)
- (mkdir-p man8)
- (for-each (lambda (file)
- (copy-file
- file
- (string-append man8 "/"
- (basename file))))
- (find-files "." "\\.8$"))
- (zero? (system* "scons" "install"
- (string-append "DESTDIR="
- bin)))))))))
- (home-page "http://code.google.com/p/exfat/")
+ (home-page "https://github.com/relan/exfat")
(synopsis "Mount exFAT file systems")
(description
"This package provides a FUSE-based file system that provides read and