summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-01-07 15:38:26 -0500
committerMark H Weaver <mhw@netris.org>2017-01-07 19:42:36 -0500
commit57fe28a082f9ff0a2d318205b4532479a74768b4 (patch)
treeea12466f92fbf4adc04b99a61b747c6918bc81a2 /gnu/packages/linux.scm
parent08600814137ef3e34b05945f02d7962206fe2e52 (diff)
downloadguix-patches-57fe28a082f9ff0a2d318205b4532479a74768b4.tar
guix-patches-57fe28a082f9ff0a2d318205b4532479a74768b4.tar.gz
gnu: linux-libre: Update to 4.9.1.
* gnu/packages/linux.scm (%linux-libre-version, %linux-libre-hash) (linux-libre): Update to 4.9.1. * gnu/packages/linux-libre-4.8-x86_64.conf, gnu/packages/linux-libre-4.8-i686.conf: Delete files. * gnu/packages/linux-libre-4.9-x86_64.conf, gnu/packages/linux-libre-4.9-i686.conf: New files. * Makefile.am (KCONFIGS): Update accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 00babcc225..10dbf20a24 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -332,8 +332,8 @@ It has been modified to remove all non-free binary blobs.")
(define %intel-compatible-systems '("x86_64-linux" "i686-linux"))
(define-public linux-libre
- (make-linux-libre "4.8.15"
- "0msgi44mh1ighfawysrzrljikwrapkvk418d6h0v45vj2i5rwln9"
+ (make-linux-libre "4.9.1"
+ "1fh2dsh58rc80jcx06s2dydcaghlnr46zaqkz6wjv9hgsd8r05bk"
%intel-compatible-systems
#:configuration-file kernel-config))
@@ -350,8 +350,8 @@ It has been modified to remove all non-free binary blobs.")
#:configuration-file kernel-config))
;; Avoid rebuilding kernel variants when there is a minor version bump.
-(define %linux-libre-version "4.8.15")
-(define %linux-libre-hash "0msgi44mh1ighfawysrzrljikwrapkvk418d6h0v45vj2i5rwln9")
+(define %linux-libre-version "4.9.1")
+(define %linux-libre-hash "1fh2dsh58rc80jcx06s2dydcaghlnr46zaqkz6wjv9hgsd8r05bk")
(define-public linux-libre-arm-generic
(make-linux-libre %linux-libre-version