summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-05-10 04:27:43 +0000
committerVagrant Cascadian <vagrant@debian.org>2021-05-29 22:11:24 -0700
commitb5069d8eaa09d20ed622b284f4004b155fc11ef8 (patch)
tree0b61aedd80392daf1436bab066d87e877df887c2 /gnu/packages/linux.scm
parentd7d6c9e4e697c33634c89628d10995d0f070db96 (diff)
downloadguix-patches-b5069d8eaa09d20ed622b284f4004b155fc11ef8.tar
guix-patches-b5069d8eaa09d20ed622b284f4004b155fc11ef8.tar.gz
gnu: linux-libre@5.12: Apply patch to fix eDP panel on Pinebook Pro.
* gnu/packages/linux.scm (linux-libre-5.12-source): Add Pinebook Pro LCD patch. (linux-libre-5.10-pristine-source): Fix whitespace and add comment.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 615a2523f9..b803426b74 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -481,14 +481,18 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(define-public linux-libre-5.12-source
(source-with-patches linux-libre-5.12-pristine-source
(list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
+ %linux-libre-arm-export-__sync_icache_dcache-patch
+ ;; Pinebook Pro patch to fix LCD display
+ (search-patch
+ "linux-libre-arm64-generic-pinebook-lcd.patch"))))
(define-public linux-libre-5.10-source
(source-with-patches linux-libre-5.10-pristine-source
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch
- (search-patch
- "linux-libre-arm64-generic-pinebook-lcd.patch"))))
+ ;; Pinebook Pro patch to fix LCD display
+ (search-patch
+ "linux-libre-arm64-generic-pinebook-lcd.patch"))))
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source