summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-07-15 17:27:56 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-07-19 16:28:08 +0300
commit703f932cc90de754abf67e21ff2c26f420bca44e (patch)
treea2e9c24860735082455fbf1bf95083481f18eb8b /gnu/packages/linux.scm
parent4cda5a4dabeba56711ca0b70f4a7be95072e522d (diff)
downloadguix-patches-703f932cc90de754abf67e21ff2c26f420bca44e.tar
guix-patches-703f932cc90de754abf67e21ff2c26f420bca44e.tar.gz
gnu: Add powercap.
* gnu/packages/linux.scm (powercap): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 41902e7785..0d695950d1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1651,6 +1651,31 @@ at login. Local and dynamic reconfiguration are its key features.")
;;; Miscellaneous.
;;;
+(define-public powercap
+ (package
+ (name "powercap")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/powercap/powercap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hp2i1d195v0n4jgvgaymkxlpgyhn07ic273gkda95lz65cdfcgm"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (home-page "https://github.com/powercap/powercap")
+ (synopsis "Utilities for accessing the powercap Linux kernel feature")
+ (description "This package contains utilities for accessing the powercap
+Linux kernel feature through sysfs. It includes an implementation for working
+with Intel @acronym{RAPL, Running Average Power Limit}.
+It provides the commands @code{powercap-info} and @code{powercap-set}.")
+ (license license:bsd-3)))
+
(define-public powerstat
(package
(name "powerstat")