summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2021-07-11 00:19:56 -0400
committerLudovic Courtès <ludo@gnu.org>2021-07-26 19:42:49 +0200
commit56de60cc27e8e9b72cf2ba3fec0d7a222704272d (patch)
treed6b3d4927e9d5bbc5a4c6f2f29ac1426298b81b2 /gnu/packages/linux.scm
parent3bbbb24f4cb84ffb83701f540a5072e20566a91a (diff)
downloadguix-patches-56de60cc27e8e9b72cf2ba3fec0d7a222704272d.tar
guix-patches-56de60cc27e8e9b72cf2ba3fec0d7a222704272d.tar.gz
gnu: interception-dual-function-keys: Minor fixes.
* gnu/packages/linux.scm (interception-dual-function-keys) [arguments]<#:make-flags>: Make use of cc-for-target, cxx-for-target and %output. <#:phases>{check}: Undelete phase. Disable tests instead with... <#:tests?>: ...this. New field. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 55a94428ed..c761652087 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3795,8 +3795,9 @@ devices that can inject events directly into the input subsystem.")
`(("libevdev" ,libevdev)
("yaml-cpp" ,yaml-cpp)))
(arguments
- `(#:make-flags (list "CC=gcc" "CXX=g++"
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
+ ,(string-append "CXX=" (cxx-for-target))
+ (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-libevdev-path
@@ -3807,9 +3808,9 @@ devices that can inject events directly into the input subsystem.")
(string-append libevdev "/include/libevdev-1.0")))
#t)))
;; No configure script
- (delete 'configure)
- ;; No target 'check'
- (delete 'check))))
+ (delete 'configure))
+ ;; No tests are included.
+ #:tests? #f))
(synopsis "Tap for one key, hold for another")
(description
"Dual Function Keys is a plugin for @code{interception-tools} that allows