summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-04 13:14:12 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-04 14:03:54 +0200
commit7394e264fced0d17dcbe98881624be8fa83165e3 (patch)
tree54606cdd67c6c224b3d778151f22adab330955b8 /gnu/packages/linux.scm
parent831f07a009e2a4d84d257ff6e07341971b0fb6e8 (diff)
downloadguix-patches-7394e264fced0d17dcbe98881624be8fa83165e3.tar
guix-patches-7394e264fced0d17dcbe98881624be8fa83165e3.tar.gz
gnu: perf: Work around GCC bug.
Works around <https://bugs.gnu.org/31708>. * gnu/packages/patches/perf-gcc-ice.patch: New patch. * gnu/packages/linux.scm (perf)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8c12141260..4d521f71b3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2500,7 +2500,9 @@ in a digital read-out.")
(package
(name "perf")
(version (package-version linux-libre))
- (source (package-source linux-libre))
+ (source (origin
+ (inherit (package-source linux-libre))
+ (patches (search-patches "perf-gcc-ice.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases