summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2018-05-18 15:18:29 -0700
committerLudovic Courtès <ludo@gnu.org>2018-05-21 00:12:02 +0200
commit5a9dc4a8074cde2fec3ecc7ea71f2e976c8c38c0 (patch)
treeccc432c196f984b879a9732f36963ae83e9fd96f /gnu/packages/linux.scm
parenta8e3fd5f9d1abd903edc9a413325194ed44557bd (diff)
downloadguix-patches-5a9dc4a8074cde2fec3ecc7ea71f2e976c8c38c0.tar
guix-patches-5a9dc4a8074cde2fec3ecc7ea71f2e976c8c38c0.tar.gz
gnu: linux-libre: Enable build for aarch64-linux.
* gnu/packages/linux.scm (%linux-compatible-systems): Add aarch64-linux. (linux-libre-4.14): Limit to x86_64-linux, i686-linux and armhf-linux. * gnu/packages/aux-files/linux-libre/4.16-arm64.conf: New file. * Makefile.am (AUX_FILES): Add 4.16-arm64.conf. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9dd9b7e883..bb4e00394f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -388,7 +388,7 @@ It has been modified to remove all non-free binary blobs.")
(license license:gpl2)))
(define %intel-compatible-systems '("x86_64-linux" "i686-linux"))
-(define %linux-compatible-systems '("x86_64-linux" "i686-linux" "armhf-linux"))
+(define %linux-compatible-systems '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux"))
;; linux-libre configuration for armhf-linux is derived from Debian armmp. It
;; supports qemu "virt" machine and possibly a large number of ARM boards.
@@ -409,7 +409,7 @@ It has been modified to remove all non-free binary blobs.")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
%linux-libre-4.14-hash
- %linux-compatible-systems
+ '("x86_64-linux" "i686-linux" "armhf-linux")
#:configuration-file kernel-config))
(define-public linux-libre-4.9