summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-05-25 19:33:31 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-05-27 19:05:34 +0200
commit2101cc3fb691f443b830fdf5f846ded5fa018739 (patch)
tree2bc77c9f975cbdfdad07b2cb6b29000efbc2629f /gnu/packages/linux.scm
parent1640f16e7888291227d11647dbb5f83ad5d138a1 (diff)
downloadguix-patches-2101cc3fb691f443b830fdf5f846ded5fa018739.tar
guix-patches-2101cc3fb691f443b830fdf5f846ded5fa018739.tar.gz
gnu: gnu: Make alsa find its plugins by setting ALSA_PLUGIN_DIR.
* gnu/packages/patches/alsa-lib-add-environment-variable.patch: New file. * gnu/packages/linux.scm (alsa-lib)[source]: Use it. [native-search-paths]: Add ALSA_PLUGIN_DIR. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7ba011bd21..466daeb2cf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -974,8 +974,15 @@ intercept and print the system calls executed by the program.")
version ".tar.bz2"))
(sha256
(base32
- "096pwrnhj36yndldvs2pj4r871zhcgisks0is78f1jkjn9sd4b2z"))))
+ "096pwrnhj36yndldvs2pj4r871zhcgisks0is78f1jkjn9sd4b2z"))
+ (patches (search-patches "alsa-lib-add-environment-variable.patch"))))
(build-system gnu-build-system)
+ (native-search-paths
+ (list (search-path-specification
+ (variable "ALSA_PLUGIN_DIR")
+ (file-type 'regular)
+ (separator #f) ;single entry
+ (files '("lib/alsa-lib")))))
(home-page "https://www.alsa-project.org/")
(synopsis "The Advanced Linux Sound Architecture libraries")
(description