summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 14:17:52 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:09:51 +0200
commit657aaa7be48c924333be70fac9f1224a26abc484 (patch)
treea5ee72c12393381ddf1afbdb91f279c76978c119 /gnu/packages/linux.scm
parentfbee3e134bc2ac22f6680d35a443b34c9606059e (diff)
downloadguix-patches-657aaa7be48c924333be70fac9f1224a26abc484.tar
guix-patches-657aaa7be48c924333be70fac9f1224a26abc484.tar.gz
gnu: efivar: Adjust for GCC 10.
* gnu/packages/patches/efivar-gcc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/linux.scm (efivar)[source](patches, modules, snippet): New fields. [arguments]: Use CC-FOR-TARGET while at it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 49c29fa470..699a01ee41 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6262,16 +6262,26 @@ under OpenGL graphics workloads.")
(uri (string-append "https://github.com/rhboot/" name
"/releases/download/" version "/" name
"-" version ".tar.bz2"))
+ (patches (search-patches "efivar-gcc-compat.patch"))
(sha256
(base32
- "17vvfivhsrszh7q39b6npjsrhrhsjf1cmmcpp3xrh6wh7ywzwrrw"))))
+ "17vvfivhsrszh7q39b6npjsrhrhsjf1cmmcpp3xrh6wh7ywzwrrw"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Compile everything within a single LTO partition
+ ;; to work around ordering issues in the code. Try
+ ;; removing this for versions > 37.
+ (substitute* "Make.defaults"
+ (("-flto")
+ "-flto -flto-partition=one"))))))
(build-system gnu-build-system)
(arguments
`(;; Tests require a UEFI system and is not detected in the chroot.
#:tests? #f
#:make-flags (list (string-append "prefix=" %output)
(string-append "libdir=" %output "/lib")
- "CC_FOR_BUILD=gcc"
+ (string-append "CC_FOR_BUILD=" ,(cc-for-target))
(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
#:phases
(modify-phases %standard-phases