summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-09-09 13:15:44 -0400
committerLeo Famulari <leo@famulari.name>2021-09-21 13:28:02 -0400
commit1e3262d74fe96cf3bc3b8b3914379ef9e37672df (patch)
tree479c832df738895225ac4d295c9f4645461dad1f /gnu/packages/linux.scm
parent1572737db34f9ec66a16adde65fda5ae4db72fd2 (diff)
downloadguix-patches-1e3262d74fe96cf3bc3b8b3914379ef9e37672df.tar
guix-patches-1e3262d74fe96cf3bc3b8b3914379ef9e37672df.tar.gz
gnu: ntfs-3g: Update to 2021.8.22 [security fixes].
The upstream security advisory is named NTFS3G-SA-2021-0001. Fixes CVE-2021-33285, CVE-2021-35269, CVE-2021-35268, CVE-2021-33289, CVE-2021-33286, CVE-2021-35266, CVE-2021-33287, CVE-2021-35267, CVE-2021-39251, CVE-2021-39252, CVE-2021-39253, CVE-2021-39254, CVE-2021-39255, CVE-2021-39256, CVE-2021-39257, CVE-2021-39258, CVE-2021-39259, CVE-2021-39260, CVE-2021-39261, CVE-2021-39262, CVE-2021-39263. For more information: https://seclists.org/oss-sec/2021/q3/139 * gnu/packages/linux.scm (ntfs-3g): Update to 2021.8.22. [source]: Remove obsolete patch. * gnu/packages/patches/ntfs-3g-CVE-2019-9755.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1934a31380..2de1efd161 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5971,15 +5971,14 @@ invocations of itself.")
(define-public ntfs-3g
(package
(name "ntfs-3g")
- (version "2017.3.23")
+ (version "2021.8.22")
(source (origin
(method url-fetch)
(uri (string-append "https://tuxera.com/opensource/"
"ntfs-3g_ntfsprogs-" version ".tgz"))
- (patches (search-patches "ntfs-3g-CVE-2019-9755.patch"))
(sha256
(base32
- "1mb228p80hv97pgk3myyvgp975r9mxq56c6bdn1n24kngcfh4niy"))
+ "1yrf42xr92qv3pads8lzp5nyssz6875ncfgg8v3jwjyr0nm87f2m"))
(modules '((guix build utils)))
(snippet '(begin
;; Install under $prefix.
@@ -5988,8 +5987,8 @@ invocations of itself.")
"@sbindir@"))
#t))))
(build-system gnu-build-system)
- (inputs `(("util-linux" ,util-linux)
- ("fuse" ,fuse))) ;libuuid
+ (inputs `(("util-linux" ,util-linux) ; libuuid
+ ("fuse" ,fuse)))
(native-inputs `(("pkg-config" ,pkg-config)))
(arguments
'(#:configure-flags (list "--disable-static"