summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-16 16:41:01 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-16 16:44:04 +0100
commit8166b6afe5e28d64d3ffd426a8153a980e2692b0 (patch)
tree5ccc3dd64b6fdb73cbcbcc78bf61d45c86ee54d7 /gnu/packages/linux.scm
parent6eae90898a8c1bcd23d156b086e7ab03930356f1 (diff)
downloadguix-patches-8166b6afe5e28d64d3ffd426a8153a980e2692b0.tar
guix-patches-8166b6afe5e28d64d3ffd426a8153a980e2692b0.tar.gz
gnu: psmisc: Fix cross-compilation.
* gnu/packages/linux.scm (psmisc)[arguments]: Pass ac_cv_func_malloc_0_nonnull=yes and ac_cv_func_realloc_0_nonnull=yes options that are required when cross-compiling.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a81905df7f..998fd20ad8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1078,6 +1078,13 @@ at login. Local and dynamic reconfiguration are its key features.")
(sha256
(base32 "16i7qzjmm6g0lzha8yzpfrlcxnvkgh95hkq9gdjd4zmzb8d0wxa1"))))
(build-system gnu-build-system)
+ (arguments
+ `(,@(if (%current-target-system)
+ '(#:configure-flags
+ (list
+ "ac_cv_func_malloc_0_nonnull=yes"
+ "ac_cv_func_realloc_0_nonnull=yes"))
+ '())))
(inputs `(("ncurses" ,ncurses)))
(home-page "https://gitlab.com/psmisc/psmisc")
(synopsis "Small utilities that use the proc file system")