summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-19 03:22:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-20 18:34:39 +0200
commit84e2853147d3fd683af2b62ad2c5c639c4894fee (patch)
tree8d2ab25ff3882f4a1868500fbf2ed9d8f8a3ea23 /gnu/packages/linux.scm
parentf9a6e3894b1648e32371e1916dfdf820de496050 (diff)
downloadguix-patches-84e2853147d3fd683af2b62ad2c5c639c4894fee.tar
guix-patches-84e2853147d3fd683af2b62ad2c5c639c4894fee.tar.gz
gnu: libbpf: Propagate pkg-config Requirements.
* gnu/packages/linux.scm (libbpf)[inputs]: Rename to, making libelf and zlib, … [propagated-inputs]: …this.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5329d70ccf..bbe801bad3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7363,11 +7363,12 @@ persistent over reboots.")
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
- (inputs
+ (propagated-inputs
+ ;; In Requires.private of libbpf.pc.
`(("libelf" ,libelf)
("zlib" ,zlib)))
(arguments
- `(#:tests? #f ; No tests
+ `(#:tests? #f ; no tests
#:make-flags
(list
(string-append "PREFIX=''")