summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:02:18 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:12:12 +0100
commit80817b509855f2e4f473372fc546c3132fa57fe7 (patch)
tree613850822508e89da1d4840a4fa58e03eada45b7 /gnu/packages/linux.scm
parent1ba5071c2d00477d8dae011c8b6b5cf532073d61 (diff)
downloadguix-patches-80817b509855f2e4f473372fc546c3132fa57fe7.tar
guix-patches-80817b509855f2e4f473372fc546c3132fa57fe7.tar.gz
gnu: multipath-tools: Update to 0.8.5.
* gnu/packages/linux.scm (multipath-tools): Update to 0.8.5. [source]: Remove patch. [arguments]: Add a ‘skip-failing-tests’ phase. * gnu/packages/patches/multipath-tools-sans-systemd.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8abeb976af..39abf6e2ba 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4430,7 +4430,7 @@ arrays when needed.")
(define-public multipath-tools
(package
(name "multipath-tools")
- (version "0.8.4")
+ (version "0.8.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4439,8 +4439,7 @@ arrays when needed.")
(file-name (git-file-name name version))
(sha256
(base32
- "14n8pcgnliicqxzc40xvjxk4cafm4qx7a3rsx5qva74r3ydzx8rn"))
- (patches (search-patches "multipath-tools-sans-systemd.patch"))
+ "0gipg0z79h76j0f449cx4wcrfsv69ravjlpphsac11h302g3nrvg"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -4498,6 +4497,18 @@ arrays when needed.")
(("-lmultipath -lcmocka")
"-lmultipath -L$(mpathcmddir) -lmpathcmd -lcmocka"))
#t))
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ ;; This test and the module's setup() test an arbitrary block
+ ;; device node name, but the build environment has none.
+ (substitute* "tests/devt.c"
+ (("return get_one_devt.*") "return 0;\n")
+ (("cmocka_unit_test\\(test_devt2devname_devt_good\\),") ""))
+ ;; The above triggers -Werror=unused-function. Ignore it.
+ (substitute* "tests/Makefile"
+ (("CFLAGS \\+= " match)
+ (string-append match "-Wno-error=unused-function ")))
+ #t))
(delete 'configure)))) ; no configure script
(native-inputs
`(("perl" ,perl)