summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-05 13:01:32 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-05 17:01:51 +0100
commit083639a5532625f2564d7ea0fb5679528be5a164 (patch)
tree416008dda0110da302659cb2cc561d36c06d995e /gnu/packages/linux.scm
parentf5e08f1793f7c36641f1b4d879b5dc3f016a4a53 (diff)
downloadguix-patches-083639a5532625f2564d7ea0fb5679528be5a164.tar
guix-patches-083639a5532625f2564d7ea0fb5679528be5a164.tar.gz
gnu: genext2fs: Update to 1.4.1-4.
* gnu/packages/linux.scm (genext2fs): Update to 1.4.1-4. [arguments]: Add 'apply-debian-patches' phase. [native-inputs]: Add autoconf and automake.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 21 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9ed46f877b..25c4a7016d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5042,17 +5042,34 @@ file systems.")
(define-public genext2fs
(package
(name "genext2fs")
- (version "1.4.1")
+ (version "1.4.1-4")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/jeremie-koenig/genext2fs.git")
- (commit (string-append "genext2fs-" version))))
+ ;; 1.4.1-3 had a VCS tag but 1.4.1-4 doesn't.
+ (commit "9ee43894634998b0b2b309d636f25c64314c9421")))
(file-name (git-file-name name version))
(sha256
- (base32
- "1r0n74pyypv63qfqqpvx75dwijcsvcrvqrlv8sldbhv0nwr1gk53"))))
+ (base32 "0ib5icn78ciz00zhc1bgdlrwaxvsdz7wnplwblng0jirwi9ml7sq"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'apply-debian-patches
+ ;; Debian changes (the revision after ‘-’ in VERSION) are
+ ;; maintained as separate patches. Apply those relevant to us.
+ (lambda _
+ (for-each
+ (lambda (file-name)
+ (invoke "patch" "-p1" "-i"
+ (string-append "debian/patches/" file-name)))
+ (list "blocksize+creator.diff" ; add -B/-o options
+ "byteswap_fix.diff"))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
(home-page "https://github.com/jeremie-koenig/genext2fs")
(synopsis "Generate ext2 filesystem as a normal user")
(description "This package provides a program to general an ext2