summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-12-05 14:45:02 -0500
committerLeo Famulari <leo@famulari.name>2020-12-06 15:51:26 -0500
commited1c72c3d7d6b6d3b110817fcc037cd5582ac848 (patch)
treed3d7e381577776d321368f17a56b790ed671598c /gnu/packages/linux.scm
parentf5138588075a5244bd3f86b4a1321ab19089af91 (diff)
downloadguix-patches-ed1c72c3d7d6b6d3b110817fcc037cd5582ac848.tar
guix-patches-ed1c72c3d7d6b6d3b110817fcc037cd5582ac848.tar.gz
gnu: alsa-plugins: Help alsa-lib find its plugins on foreign distros.
Fixes <https://bugs.gnu.org/40832>. * gnu/packages/linux.scm (alsa-pluins)[native-search-paths]: Set ALSA_PLUGIN_DIR.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index daf73f8b40..eadbaa8f35 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2149,6 +2149,11 @@ MIDI functionality to the Linux-based operating system.")
;; ALSA applications on OSS however we do not offer OSS and OSS is
;; obsolete.
(outputs '("out" "pulseaudio" "jack"))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "ALSA_PLUGIN_DIR")
+ (files '("lib/alsa-lib"))
+ (separator #f))))
(arguments
`(#:configure-flags '(;; Do not install a "local" configuration targeted
;; for /etc/alsa. On Guix System plugins are loaded from