summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-13 22:45:32 +0200
committerDavid Craven <david@craven.ch>2016-09-13 22:48:00 +0200
commitd6feaf6e8ffbc34f05bdff0672485416997984ec (patch)
tree1161bd75ece4b1372e5a26c81378cc96a5b99204 /gnu/packages/linux.scm
parent0b759869832817312c40bb0a6e45cc3114b9580b (diff)
downloadguix-patches-d6feaf6e8ffbc34f05bdff0672485416997984ec.tar
guix-patches-d6feaf6e8ffbc34f05bdff0672485416997984ec.tar.gz
gnu: kernel-config: Remove redundant file-exists? check.
* gnu/packages/linux.scm (kernel-config): Remove redundant file-exists? check.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8c1cbeaa65..3ec65141af 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -184,7 +184,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(if variant (string-append variant "-") "")
arch ".conf"))
(file (string-append "gnu/packages/" name)))
- (if file-exists? (search-path %load-path file) #f)))
+ (search-path %load-path file)))
(define %default-extra-linux-options
`(("CONFIG_NET_9P" . m)