summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-13 20:58:07 +0200
committerDavid Craven <david@craven.ch>2016-09-13 21:01:27 +0200
commitcff0adec0c621f77238f533a2cf544f9bc33c659 (patch)
treeef459e2e3255b42191596d9f861df62cfca00a6b /gnu/packages/linux.scm
parentde459dc095c4db1d1a0ea590519632724e4646db (diff)
downloadguix-patches-cff0adec0c621f77238f533a2cf544f9bc33c659.tar
guix-patches-cff0adec0c621f77238f533a2cf544f9bc33c659.tar.gz
gnu: libnfsidmap: Move to (gnu packages linux).
* gnu/packages/linux.scm (libnfsidmap): Move.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm58
1 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fde62bdac6..455947d1e4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -199,35 +199,6 @@
`insmod', `lsmod', and more.")
(license license:gpl2+)))
-(define-public libnfsidmap
- (package
- (name "libnfsidmap")
- (version "0.25")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.citi.umich.edu/projects/nfsv4/linux/"
- name "/" name "-" version ".tar.gz"))
- (sha256
- (base32
- "1kzgwxzh83qi97rblcm9qj80cdvnv8kml2plz0q103j0hifj8vb5"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags (list
- (string-append "--with-pluginpath="
- (assoc-ref %outputs "out")
- "/lib/libnfsidmap"))))
- (home-page
- "http://www.citi.umich.edu/projects/nfsv4/crossrealm/libnfsidmap_config.html")
- (synopsis
- "NFSv4 support library for name/ID mapping")
- (description "Libnfsidmap is a library holding mulitiple methods of
-mapping names to ids and visa versa, mainly for NFSv4. It provides an
-extensible array of mapping functions, currently consisting of two choices:
-the default @code{nsswitch} and the experimental @code{umich_ldap}.")
- (license (license:non-copyleft "file://COPYING"
- "See COPYING in the distribution."))))
-
(define %boot-logo-patch
;; Linux-Libre boot logo featuring Freedo and a gnu.
(origin
@@ -2940,3 +2911,32 @@ native Linux file system, and has been part of the Linux kernel since version
;; The files src/key_mod/ecryptfs_key_mod_{openssl,pkcs11_helper,tspi}.c
;; grant additional permission to link with OpenSSL.
(license license:gpl2+)))
+
+(define-public libnfsidmap
+ (package
+ (name "libnfsidmap")
+ (version "0.25")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.citi.umich.edu/projects/nfsv4/linux/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kzgwxzh83qi97rblcm9qj80cdvnv8kml2plz0q103j0hifj8vb5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list
+ (string-append "--with-pluginpath="
+ (assoc-ref %outputs "out")
+ "/lib/libnfsidmap"))))
+ (home-page
+ "http://www.citi.umich.edu/projects/nfsv4/crossrealm/libnfsidmap_config.html")
+ (synopsis
+ "NFSv4 support library for name/ID mapping")
+ (description "Libnfsidmap is a library holding mulitiple methods of
+mapping names to ids and visa versa, mainly for NFSv4. It provides an
+extensible array of mapping functions, currently consisting of two choices:
+the default @code{nsswitch} and the experimental @code{umich_ldap}.")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))