summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-08 16:18:54 +0200
committerDavid Craven <david@craven.ch>2016-09-13 16:45:41 +0200
commit9416459b7294e7229613f15a475ea8a65f0cc303 (patch)
treeb87c8c11096414c547461d81307a644c93511a2f /gnu/packages/linux.scm
parent499fb7e0baf0ec43ef9aac6d663da95415041954 (diff)
downloadguix-patches-9416459b7294e7229613f15a475ea8a65f0cc303.tar
guix-patches-9416459b7294e7229613f15a475ea8a65f0cc303.tar.gz
gnu: linux-libre: Move kernel configuration to configure phase.
* gnu/packages/linux.scm (linux-libre)[arguments]: Add configure phase.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a7eaae9b39..cb374e49be 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -290,9 +290,8 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
(ice-9 match))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
;; Avoid introducing timestamps
(setenv "KCONFIG_NOTIMESTAMP" "1")
(setenv "KBUILD_BUILD_TIMESTAMP" (getenv "SOURCE_DATE_EPOCH"))
@@ -333,11 +332,7 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
port)
(close-port port))
- (zero? (system* "make" "oldconfig"))
-
- ;; Call the default `build' phase so `-j' is correctly
- ;; passed.
- (apply build #:make-flags "all" args))))
+ (zero? (system* "make" "oldconfig")))))
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))