summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-08 19:27:52 +0200
committerDavid Craven <david@craven.ch>2016-09-13 21:01:27 +0200
commit78edccccaf3bb0091b7edc97f0d92b15b1f23078 (patch)
treeb4f3142b1bd71e53a46f7c6608606c5d2394221a /gnu/packages/linux.scm
parent3129b9c2b17943a76fa243d30387ca01593fbf6a (diff)
downloadguix-patches-78edccccaf3bb0091b7edc97f0d92b15b1f23078.tar
guix-patches-78edccccaf3bb0091b7edc97f0d92b15b1f23078.tar.gz
gnu: linux-libre: Use kmod.
* gnu/packages/linux.scm (make-linux-libre): Use kmod.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index eabcbbe2ae..96ab43b95b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -296,7 +296,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
`(("perl" ,perl)
("bc" ,bc)
("openssl" ,openssl)
- ("module-init-tools" ,module-init-tools)
+ ("kmod" ,kmod)
,@(let ((conf (configuration-file
(system->linux-architecture
(or (%current-target-system)
@@ -355,7 +355,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(moddir (string-append out "/lib/modules"))
- (mit (assoc-ref (or native-inputs inputs) "module-init-tools")))
+ (kmod (assoc-ref (or native-inputs inputs) "kmod")))
(mkdir-p moddir)
(for-each (lambda (file)
(copy-file file
@@ -363,7 +363,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(find-files "." "^(bzImage|zImage|vmlinuz|System\\.map)$"))
(copy-file ".config" (string-append out "/config"))
(zero? (system* "make"
- (string-append "DEPMOD=" mit "/sbin/depmod")
+ (string-append "DEPMOD=" kmod "/bin/depmod")
(string-append "MODULE_DIR=" moddir)
(string-append "INSTALL_PATH=" out)
(string-append "INSTALL_MOD_PATH=" out)