summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-15 21:54:01 +0200
committerDavid Craven <david@craven.ch>2016-09-15 21:57:51 +0200
commit25847b327e9add2c55ba4980a95708484db46473 (patch)
tree16280ce9d9eda7a05255f0a28ceda33be9f7fc36 /gnu/packages/linux.scm
parent4a187c556d9e6c3f053efd80f3b1fdecbc02e40e (diff)
downloadguix-patches-25847b327e9add2c55ba4980a95708484db46473.tar
guix-patches-25847b327e9add2c55ba4980a95708484db46473.tar.gz
gnu: kernel-config: Find configuration file for i686.
* gnu/packages/linux.scm (kernel-config): Find configuration file for i686. (make-linux-libre)[origin]: Apply patch correctly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3ec65141af..cdb06b5e36 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -182,7 +182,7 @@
for ARCH and optionally VARIANT, or #f if there is no such configuration."
(let* ((name (string-append "linux-libre-"
(if variant (string-append variant "-") "")
- arch ".conf"))
+ (if (string=? "i386" arch) "i686" arch) ".conf"))
(file (string-append "gnu/packages/" name)))
(search-path %load-path file)))
@@ -228,7 +228,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(method url-fetch)
(uri (linux-libre-urls version))
(sha256 (base32 hash))
- (patches (origin-patches %boot-logo-patch))))
+ (patches (list %boot-logo-patch))))
(supported-systems supported-systems)
(build-system gnu-build-system)
(native-inputs