summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-30 00:55:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-30 01:08:53 +0100
commitc1546d8a684cb91b8b69975895f65d85f5e056bb (patch)
treee16d71aceb5f9b8871d043c6df25197a08772e78 /gnu/packages/linux.scm
parent2397cc097c33b37ffad6332c6e13f89aabc7cc9d (diff)
downloadguix-patches-c1546d8a684cb91b8b69975895f65d85f5e056bb.tar
guix-patches-c1546d8a684cb91b8b69975895f65d85f5e056bb.tar.gz
gnu: powerstat: Fetch sources from Git.
* gnu/packages/linux.scm (powerstat)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8a14e4e1d9..9b4934c338 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1740,11 +1740,13 @@ It provides the commands @code{powercap-info} and @code{powercap-set}.")
(version "0.02.26")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://kernel.ubuntu.com/~cking/tarballs/"
- "powerstat/powerstat-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ColinIanKing/powerstat")
+ (commit (string-append "V" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "18m85k83hryj05vix63fay1hh0sb9h87hy5r7g1dqg2y9i8lzgxk"))))
+ (base32 "0jp9dvwlz4svg28vgrgvvbi72ca9mkfczy0f05vvsgpxjz7hlfnj"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags