summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-10 11:08:47 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:37 -0500
commit4b1538e6ef76bf46993f0a368a0abbe2f6eb8ffb (patch)
treeb10ceb23c6d93dabc3c50b6d5127fff16ffa8719 /gnu/packages/linux.scm
parentd26584fcdac80058eea9a98be89ed120945e0b1b (diff)
downloadguix-patches-4b1538e6ef76bf46993f0a368a0abbe2f6eb8ffb.tar
guix-patches-4b1538e6ef76bf46993f0a368a0abbe2f6eb8ffb.tar.gz
gnu: kexec-tools: Fix build on i686-linux.
* gnu/packages/linux.scm (kexec-tools) [native-inputs]: Add binutils-next and its accompanying wrapper.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f65b87c3b6..7005774b1d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8365,6 +8365,11 @@ line for tracing control, a @code{lttng-ctl} library for tracing control and a
(arguments
;; There are no automated tests.
'(#:tests? #f))
+ ;; This variant of binutils is used for the 64 bit support needed to
+ ;; assemble the `purgatory/arch/i386/compat_x86_64.S' program on i686-linux.
+ (native-inputs (list (make-ld-wrapper "ld-wrapper"
+ #:binutils binutils-next)
+ binutils-next))
(home-page "https://projects.horms.net/projects/kexec/")
(synopsis "Tools for booting directly into different kernels")
(description "This package provides the @code{kexec} program and ancillary