summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-11-26 12:54:50 -0500
committerLeo Famulari <leo@famulari.name>2021-11-26 16:54:47 -0500
commit14f6c21077c1af81ea1a599ccaeedcd983c332fd (patch)
tree513ead30b35d117c0f4c770af3c5bc16ad827a39 /gnu/packages/linux.scm
parent65401faa9c264abe562fdd77923287b99f11c49b (diff)
downloadguix-patches-14f6c21077c1af81ea1a599ccaeedcd983c332fd.tar
guix-patches-14f6c21077c1af81ea1a599ccaeedcd983c332fd.tar.gz
gnu: Add linux-libre 5.15.5.
* gnu/packages/linux.scm (linux-libre-5.15-version, linux-libre-5.15-gnu-revision, deblob-scripts-5.15, linux-libre-5.15-pristine-source, linux-libre-5.15-source, linux-libre-headers-5.15, linux-libre-5.15): New variables. * gnu/packages/aux-files/linux-libre/5.15-arm.conf, gnu/packages/aux-files/linux-libre/5.15-arm64.conf, gnu/packages/aux-files/linux-libre/5.15-i686.conf, gnu/packages/aux-files/linux-libre/5.15-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e6d88076e0..265fbc30f3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -348,6 +348,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+(define-public linux-libre-5.15-version "5.15.5")
+(define-public linux-libre-5.15-gnu-revision "gnu")
+(define deblob-scripts-5.15
+ (linux-libre-deblob-scripts
+ linux-libre-5.15-version
+ linux-libre-5.15-gnu-revision
+ (base32 "1rfhwfzifmbpnrhmrn3srm736nkm1v6affw915d0fgqzqgi8qfai")
+ (base32 "04fj1x3zmi310cr3m9hxpi26gdcmwfsqciv5yb6q6rrnqjqs1pc0")))
+(define-public linux-libre-5.15-pristine-source
+ (let ((version linux-libre-5.15-version)
+ (hash (base32 "07w5k2y5hk6ys19zgg3x21g6im9x0pwk5f6f8b0q3b152lq5lmp9")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.15)))
+
(define-public linux-libre-5.14-version "5.14.21")
(define-public linux-libre-5.14-gnu-revision "gnu")
(define deblob-scripts-5.14
@@ -484,6 +499,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.15-source
+ (source-with-patches linux-libre-5.15-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.14-source
(source-with-patches linux-libre-5.14-pristine-source
(list %boot-logo-patch
@@ -596,6 +616,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.15
+ (make-linux-libre-headers* linux-libre-5.15-version
+ linux-libre-5.15-gnu-revision
+ linux-libre-5.15-source))
+
(define-public linux-libre-headers-5.14
(make-linux-libre-headers* linux-libre-5.14-version
linux-libre-5.14-gnu-revision
@@ -902,6 +927,13 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-5.15
+ (make-linux-libre* linux-libre-5.15-version
+ linux-libre-5.15-gnu-revision
+ linux-libre-5.15-source
+ '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-5.14
(make-linux-libre* linux-libre-5.14-version
linux-libre-5.14-gnu-revision