summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-11-26 12:59:25 -0500
committerLeo Famulari <leo@famulari.name>2021-11-26 16:54:47 -0500
commit0384bceadb8c99c0518a2693996203738815cfef (patch)
treefdaec5dbe09dad14b20d30ed777077a4e81ac9ad /gnu/packages/linux.scm
parent8fb949f988e3c6e92f928175d2823add1ee8c885 (diff)
downloadguix-patches-0384bceadb8c99c0518a2693996203738815cfef.tar
guix-patches-0384bceadb8c99c0518a2693996203738815cfef.tar.gz
gnu: Remove linux-libre 5.14.
* gnu/packages/linux.scm (linux-libre-5.14-version, linux-libre-5.14-gnu-revision, deblob-scripts-5.14, linux-libre-5.14-pristine-source, linux-libre-5.14-source, linux-libre-headers-5.14, linux-libre-5.14): Remove variables. * gnu/packages/aux-files/linux-libre/5.14-arm.conf, gnu/packages/aux-files/linux-libre/5.14-arm64.conf, gnu/packages/aux-files/linux-libre/5.14-i686.conf, gnu/packages/aux-files/linux-libre/5.14-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d653026450..481be24cfd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -363,21 +363,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
-(define-public linux-libre-5.14-version "5.14.21")
-(define-public linux-libre-5.14-gnu-revision "gnu")
-(define deblob-scripts-5.14
- (linux-libre-deblob-scripts
- linux-libre-5.14-version
- linux-libre-5.14-gnu-revision
- (base32 "11zax57brk8bl75q68c71xsdlvslj48wpmrv8rh34sb8wym9n4mc")
- (base32 "1xmmr26lpffc4dfmrkvh3gdkkr8666fcyvgam560vbyd2b2qkd78")))
-(define-public linux-libre-5.14-pristine-source
- (let ((version linux-libre-5.14-version)
- (hash (base32 "1cr381c179nfdrq95l4j56c4ygw09sxv493553ix4b80naf2a6pl")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-5.14)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
@@ -504,14 +489,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-5.14-source
- (source-with-patches linux-libre-5.14-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch
- ;; Pinebook Pro patch to fix LCD display
- (search-patch
- "linux-libre-arm64-generic-pinebook-lcd.patch"))))
-
(define-public linux-libre-5.10-source
(source-with-patches linux-libre-5.10-pristine-source
(list %boot-logo-patch
@@ -621,11 +598,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-5.15-gnu-revision
linux-libre-5.15-source))
-(define-public linux-libre-headers-5.14
- (make-linux-libre-headers* linux-libre-5.14-version
- linux-libre-5.14-gnu-revision
- linux-libre-5.14-source))
-
(define-public linux-libre-headers-5.10
(make-linux-libre-headers* linux-libre-5.10-version
linux-libre-5.10-gnu-revision
@@ -934,13 +906,6 @@ It has been modified to remove all non-free binary blobs.")
'("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-5.14
- (make-linux-libre* linux-libre-5.14-version
- linux-libre-5.14-gnu-revision
- linux-libre-5.14-source
- '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-version linux-libre-5.15-version)
(define-public linux-libre-gnu-revision linux-libre-5.15-gnu-revision)
(define-public linux-libre-pristine-source linux-libre-5.15-pristine-source)