summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-12-28 21:30:40 -0500
committerLeo Famulari <leo@famulari.name>2020-12-29 01:28:10 -0500
commit8727870ff4e4d5016431985a888f3ca589d81e02 (patch)
tree4b2c926250e026cb2e766c22afe38d5afd91e94e /gnu/packages/linux.scm
parent1ab6ccb77de487a6817ee03073163fd1864e28d2 (diff)
downloadguix-patches-8727870ff4e4d5016431985a888f3ca589d81e02.tar
guix-patches-8727870ff4e4d5016431985a888f3ca589d81e02.tar.gz
gnu: Remove linux-libre 5.9.
The 5.9 kernel series is no longer supported upstream. * gnu/packages/linux.scm (linux-libre-5.9-version, deblob-scripts-5.9, linux-libre-5.9-pristine-source, linux-libre-5.9-source, linux-libre-headers-5.9, linux-libre-5.9): Remove variables.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index af28d00acc..3df0159f82 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -365,19 +365,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.10)))
-(define-public linux-libre-5.9-version "5.9.16")
-(define deblob-scripts-5.9
- (linux-libre-deblob-scripts
- linux-libre-5.9-version
- (base32 "1l0iw2lp6alk0a8nvdafklyks83iiyw4b2r5xif84z47qfbydsis")
- (base32 "1vrv78xwcy32b82plkkbpyfxhpy3br7b18sjah4iqv25fxfcxpak")))
-(define-public linux-libre-5.9-pristine-source
- (let ((version linux-libre-5.9-version)
- (hash (base32 "11mbnjvb5d5gwbrwlkqvzpg1ij4m19l5wr3wca9iiyg5i2papmxh")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-5.9)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
@@ -479,11 +466,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-5.9-source
- (source-with-patches linux-libre-5.9-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
-
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source
(list %boot-logo-patch
@@ -587,10 +569,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(make-linux-libre-headers* linux-libre-5.10-version
linux-libre-5.10-source))
-(define-public linux-libre-headers-5.9
- (make-linux-libre-headers* linux-libre-5.9-version
- linux-libre-5.9-source))
-
(define-public linux-libre-headers-5.4
(make-linux-libre-headers* linux-libre-5.4-version
linux-libre-5.4-source))
@@ -889,12 +867,6 @@ It has been modified to remove all non-free binary blobs.")
(define-public linux-libre-source linux-libre-5.10-source)
(define-public linux-libre linux-libre-5.10)
-(define-public linux-libre-5.9
- (make-linux-libre* linux-libre-5.9-version
- linux-libre-5.9-source
- '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-5.4
(make-linux-libre* linux-libre-5.4-version
linux-libre-5.4-source