summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-18 00:37:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-18 00:39:25 +0100
commitff9d1a2f0c9cc82ae4c73d8660a87829bae9bf30 (patch)
treec6a0693694b3b7d93de3fa2c8eef099bc08e66ad /gnu/packages/linux.scm
parent6f6db0269f76525e91201038b77798d666c8130b (diff)
parenta01d926f9d10bb504ae4304567924e43368d4954 (diff)
downloadguix-patches-ff9d1a2f0c9cc82ae4c73d8660a87829bae9bf30.tar
guix-patches-ff9d1a2f0c9cc82ae4c73d8660a87829bae9bf30.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 78d23b4f6a..aebbfccdbf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3153,10 +3153,12 @@ and copy/paste text in the console and in xterm.")
(lambda _ (zero? (system* "make" "static"))))
(add-after 'install 'install-bash-completion
(lambda* (#:key outputs #:allow-other-keys)
- (install-file "btrfs-completion"
- (string-append (assoc-ref outputs "out")
- "/etc/bash_completion.d"))
- #t))
+ (let* ((out (assoc-ref outputs "out"))
+ (bashcomp (string-append out "/etc/bash_completion.d")))
+ (mkdir-p bashcomp)
+ (copy-file "btrfs-completion"
+ (string-append bashcomp "/btrfs"))
+ #t)))
(add-after 'install 'install-static
(let ((staticbin (string-append (assoc-ref %outputs "static")
"/bin")))