summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2020-07-10 00:15:42 -0400
committerMark H Weaver <mhw@netris.org>2020-07-10 00:15:42 -0400
commit3f4f0770512b286523a398e3f9f3eb6441f44b17 (patch)
tree6270ba98c497d5b0dc79a5e4073a243a2cf0418c /gnu/packages/linux.scm
parent1e8b8dcf558ef9ba7dbcf59f34cab6c5415df36d (diff)
downloadguix-patches-3f4f0770512b286523a398e3f9f3eb6441f44b17.tar
guix-patches-3f4f0770512b286523a398e3f9f3eb6441f44b17.tar.gz
gnu: linux-libre: Fix regression with Atheros 9271.
* gnu/packages/patches/linux-libre-fix-atheros-9271.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/linux.scm (%linux-libre-fix-atheros-9271-patch): New variable. (linux-libre-4.4-source, linux-libre-4.9-source) (linux-libre-4.14-source, linux-libre-4.19-source) (linux-libre-5.4-source, linux-libre-5.7-source): Add the patch.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d0fe5ee57a..bd7cbf183f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -443,6 +443,9 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(sha256
(base32 "1ifnfhpakzffn4b8n7x7w5cps9mzjxlkcfz9zqak2vaw8nzvl39f"))))
+(define %linux-libre-fix-atheros-9271-patch
+ (search-patch "linux-libre-fix-atheros-9271.patch"))
+
(define (source-with-patches source patches)
(origin
(inherit source)
@@ -452,12 +455,14 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(define-public linux-libre-5.7-source
(source-with-patches linux-libre-5.7-pristine-source
(list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
+ %linux-libre-arm-export-__sync_icache_dcache-patch
+ %linux-libre-fix-atheros-9271-patch)))
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch
+ %linux-libre-fix-atheros-9271-patch
;; Pinebook Pro patch from linux-next,
;; can be dropped for linux-libre 5.7
(search-patch
@@ -466,19 +471,23 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(define-public linux-libre-4.19-source
(source-with-patches linux-libre-4.19-pristine-source
(list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
+ %linux-libre-arm-export-__sync_icache_dcache-patch
+ %linux-libre-fix-atheros-9271-patch)))
(define-public linux-libre-4.14-source
(source-with-patches linux-libre-4.14-pristine-source
- (list %boot-logo-patch)))
+ (list %boot-logo-patch
+ %linux-libre-fix-atheros-9271-patch)))
(define-public linux-libre-4.9-source
(source-with-patches linux-libre-4.9-pristine-source
- (list %boot-logo-patch)))
+ (list %boot-logo-patch
+ %linux-libre-fix-atheros-9271-patch)))
(define-public linux-libre-4.4-source
(source-with-patches linux-libre-4.4-pristine-source
- (list %boot-logo-patch)))
+ (list %boot-logo-patch
+ %linux-libre-fix-atheros-9271-patch)))
;;;