summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-12 17:00:11 +0100
committerMarius Bakke <marius@gnu.org>2022-12-12 20:23:31 +0100
commit61f67290b95adb537eebde13251d5c1c2dfc1687 (patch)
tree76b4ed917ce0cb79e55c0dbe794ad441dc272567 /gnu/packages/linux.scm
parent58e33da5f5261bbc3f76fd10b4807ff493ad587c (diff)
downloadguix-patches-61f67290b95adb537eebde13251d5c1c2dfc1687.tar
guix-patches-61f67290b95adb537eebde13251d5c1c2dfc1687.tar.gz
gnu: f2fs-tools: Don't fetch autogenerated git snapshot.
* gnu/packages/linux.scm (f2fs-tools)[source]: Switch to GIT-FETCH.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ad892a332d..485bc6d0f5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5937,13 +5937,15 @@ obviously it can be shared with files outside our set).")
(name "f2fs-tools")
(version "1.14.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://git.kernel.org/cgit/linux/kernel/git/jaegeuk"
- "/f2fs-tools.git/snapshot/f2fs-tools-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/linux/kernel\
+/git/jaegeuk/f2fs-tools.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1lab1446c78xsjwhpki7s85z4171m8p9279c8yhm4882wba674k1"))))
+ "06ss05n87i1c3149qb3n7j1qp2scv3g2adx0v6ljkl59ab9b5saj"))))
(build-system gnu-build-system)
(arguments
'(#:phases