summaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-16 12:22:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-29 01:17:06 -0400
commitebc75b6ae8205c9a23826453db2e6ac4ce37ff0d (patch)
treed0f9f8ffb3445ac1ecd36d01c31d6f8f322898c4 /gnu/packages/linphone.scm
parent7a8e17343d3b8fbf394e8ef091852ea54d9fc741 (diff)
downloadguix-patches-ebc75b6ae8205c9a23826453db2e6ac4ce37ff0d.tar
guix-patches-ebc75b6ae8205c9a23826453db2e6ac4ce37ff0d.tar.gz
gnu: bzrtp: Update to 4.4.34 and enable tests.
* gnu/packages/linphone.scm (bzrtp)[source]: Switch to git repository. [version]: Update to 4.4.34. [configure-flags]: Enable tests. [license]: Upgrade to GPLv3+. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index d1648418e5..60221ffad8 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -425,20 +425,22 @@ implements the RFC 3550 standard.")
(define-public bzrtp
(package
(name "bzrtp")
- (version "1.0.6")
+ (version "4.4.34")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "https://www.linphone.org/releases/sources/" name
- "/" name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.linphone.org/BC/public/bzrtp")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "12y0kkh90pixaaxfyx26ca2brhy6nw57fsypp6vh8jk1illv0j5z"))))
+ (base32 "1yjmsbqmymzl4r7sba6w4a2yld8m6hzafr6jf7sj0syhwpnc3zv6"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; No test target
- #:configure-flags
- (list "-DENABLE_STATIC=NO"))) ; Not required
+ `(#:configure-flags
+ (list
+ "-DENABLE_STATIC=NO"
+ "-DENABLE_TESTS=YES")))
(inputs
`(("bctoolbox" ,bctoolbox)
("sqlite3" ,sqlite)
@@ -448,7 +450,7 @@ implements the RFC 3550 standard.")
written in C. It is fully portable and can be executed on many platforms
including both ARM and x86.")
(home-page "https://gitlab.linphone.org/BC/public/bzrtp")
- (license license:gpl2+)))
+ (license license:gpl3+)))
(define-public belle-sip
(package