summaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-14 23:40:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-29 01:12:48 -0400
commitc52d0f9c42596404180f1d3f06c646b25b3ac541 (patch)
tree924a8245791d7cd6f37af984bed3740a1c8f7474 /gnu/packages/linphone.scm
parentbdd0d5bfbd494ad14393e5b558abf959dada56e3 (diff)
downloadguix-patches-c52d0f9c42596404180f1d3f06c646b25b3ac541.tar
guix-patches-c52d0f9c42596404180f1d3f06c646b25b3ac541.tar.gz
gnu: belr: Update to 4.4.34 and enable tests.
* gnu/packages/linphone.scm (belr)[source]: Switch to git repository. [version]: Update to 4.4.34. [arguments]: Remove the tests? argument to enable tests. [phases]{move-tester, check}: New phases. Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm43
1 files changed, 34 insertions, 9 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index cfe05eaa7a..3e46d23838 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -190,20 +190,45 @@ Communications software like belle-sip, mediastreamer2 and linphone.")
(define-public belr
(package
(name "belr")
- (version "0.1.3")
+ (version "4.4.34")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "https://www.linphone.org/releases/sources/" name
- "/" name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.linphone.org/BC/public/belr.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1fwv2cg3qy9vdc7dimcda7nqcqc1h2cdd7ikhk7ng7q4ys8m96c1"))))
+ (base32 "0w2canwwm0qb99whnangvaybvjzq8xg6vksqxykgr8fbx7clw03h"))))
(build-system cmake-build-system)
+ (outputs '("out" "debug" "tester"))
(arguments
- `(#:tests? #f ; No test target
- #:configure-flags
- (list "-DENABLE_STATIC=OFF"))) ; Not required
+ `(#:configure-flags '("-DENABLE_STATIC=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check) ;moved after the install phase
+ (add-after 'install 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((tester (assoc-ref outputs "tester"))
+ (belr_tester (string-append tester "/bin/belr_tester"))
+ (tester-share (string-append tester "/share/belr_tester")))
+ (invoke belr_tester))))
+ (add-after 'install 'move-tester
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (tester (assoc-ref outputs "tester")))
+ (for-each mkdir-p
+ (list (string-append tester "/bin")
+ (string-append tester "/share")))
+ (rename-file
+ (string-append out "/bin/belr_tester")
+ (string-append tester "/bin/belr_tester"))
+ (rename-file
+ (string-append out "/share/belr-tester")
+ ;; The detect_res_prefix procedure in bctoolbox's tester.c
+ ;; resolves the resource path based on the executable path and
+ ;; name, so have it match.
+ (string-append tester "/share/belr_tester"))))))))
(inputs
`(("bctoolbox" ,bctoolbox)))
(synopsis "Belledonne Communications Language Recognition Library")