summaryrefslogtreecommitdiff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-07-27 13:10:29 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-08-14 20:21:43 -0400
commit8729c8be1b8403322ae80115c2daf0c8803223e8 (patch)
treebcd8be76aae167e50c5e8245167b307017665e5e /gnu/packages/libusb.scm
parentfb6b9f3b72d110c825f01823b9d00573fde68b0f (diff)
downloadguix-patches-8729c8be1b8403322ae80115c2daf0c8803223e8.tar
guix-patches-8729c8be1b8403322ae80115c2daf0c8803223e8.tar.gz
gnu: libplist: Update to 2.2.0.
* gnu/packages/libusb.scm (libplist): Update to 2.2.0. [source]: Use 'url-fetch' instead of 'git-fetch'. [home-page]: Update URL.
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 7b13d98d95..61707490ad 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -351,16 +351,15 @@ I2C and SPI devices attached to the USB Hub.")
(define-public libplist
(package
(name "libplist")
- (version "2.1.0")
+ (version "2.2.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/libimobiledevice/libplist")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://github.com/libimobiledevice"
+ "/libplist/releases/download/" version
+ "/libplist-" version ".tar.bz2"))
(sha256
- (base32 "02vraf4j46bp746s0gz7vga2gv2dy3zd1v1bsy9x8algg9fpcb7n"))))
+ (base32 "16mxdwaw01x9a3adf0yj3bqjc7afpf2vm1n5hkgj3i3y6zjifmaa"))))
(build-system gnu-build-system)
(arguments
`(;; Tests fail randomly when run in parallel because several of them write
@@ -375,7 +374,7 @@ I2C and SPI devices attached to the USB Hub.")
("libtool" ,libtool)
("pkg-config" ,pkg-config)
("python-cython" ,python-cython))) ; to build Python bindings
- (home-page "https://www.libimobiledevice.org/")
+ (home-page "https://libimobiledevice.org/")
(synopsis "C library to handle Apple Property List files")
(description "This package provides a small portable C library to handle
Apple Property List files in binary or XML.")