summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2018-09-11 07:59:11 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-11 17:46:30 +0200
commit52b0a352c376eaed4ae7cf109f66538d6ac0a859 (patch)
tree40159966bec76ffdc66be5cb5897aa55161d5c0b /gnu/packages/libreoffice.scm
parentaeba7d4650f6d725f4751aa142cd1aae5ee3be97 (diff)
downloadguix-patches-52b0a352c376eaed4ae7cf109f66538d6ac0a859.tar
guix-patches-52b0a352c376eaed4ae7cf109f66538d6ac0a859.tar.gz
gnu: libreoffice: Update to 6.1.0.3.
* gnu/packages/libreoffice.scm (libreoffice): Update to 6.1.0.3. [source]: Correct indenting. [inputs]: Add libnumbertext and python-lxml. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index d81f8aa793..cf8082bcaa 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -926,19 +926,19 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "6.0.6.2")
+ (version "6.1.0.3")
(source
(origin
- (method url-fetch)
- (uri
+ (method url-fetch)
+ (uri
(string-append
- "https://download.documentfoundation.org/libreoffice/src/"
- (version-prefix version 3) "/libreoffice-" version ".tar.xz"))
- (sha256
- (base32
- "13kaikaz65xw9a3hxbh245cnydjpy58np22c7s0s65pnmcq68rpi"))
- (patches (search-patches "libreoffice-icu.patch"
- "libreoffice-glm.patch"))))
+ "https://download.documentfoundation.org/libreoffice/src/"
+ (version-prefix version 3) "/libreoffice-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1n7b6abc0bp9x8lddx60w5br444wf62mdlkqmfk2zmkmiwkcvv2l"))
+ (patches (search-patches "libreoffice-icu.patch"
+ "libreoffice-glm.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
@@ -979,6 +979,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("libltdl" ,libltdl)
("libmspub" ,libmspub)
("libmwaw" ,libmwaw)
+ ("libnumbertext" ,libnumbertext)
("libodfgen" ,libodfgen)
("libpagemaker" ,libpagemaker)
("libqxp" ,libqxp)
@@ -1005,6 +1006,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("poppler" ,poppler)
("postgresql" ,postgresql)
("python" ,python)
+ ("python-lxml" ,python-lxml)
("redland" ,redland)
("sane-backends" ,sane-backends)
("unixodbc" ,unixodbc)