summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-08 17:53:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 18:38:00 +0200
commit5124e6377578c0346efa7d839b5c4e5cfc1d6d72 (patch)
tree0ac566e6c2c5b2f6e189b9503e91205ee594f217 /gnu/packages/libreoffice.scm
parent2036709b7f7bcf522a392600361923d1ff27bdc6 (diff)
downloadguix-patches-5124e6377578c0346efa7d839b5c4e5cfc1d6d72.tar
guix-patches-5124e6377578c0346efa7d839b5c4e5cfc1d6d72.tar.gz
gnu: libvisio: Update to 0.1.5.
* gnu/packages/patches/libvisio-fix-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/libreoffice.scm (libvisio): Update to 0.1.5. [source]: Add 'libvisio-fix-tests.patch'. [arguments]: Remove.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 535772dfff..9c392c536b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -537,15 +537,15 @@ created by PageMaker version 6.x and 7.")
(define-public libvisio
(package
(name "libvisio")
- ;; FIXME: The newer version 0.1.1 fails its tests.
- (version "0.1.0")
+ (version "0.1.5")
(source
(origin
(method url-fetch)
(uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "libvisio-fix-tests.patch"))
(sha256 (base32
- "0vvd2wyp4rw6s9xnj1dc9vgdpfvm45gnb5b9hhzif0fdnx4iskqf"))))
+ "132szijxm95ibzq5qqaylifbf6wa81g08jxggnwv22v60dwhc2j3"))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
@@ -559,10 +559,6 @@ created by PageMaker version 6.x and 7.")
("libxml2" ,libxml2)))
(inputs
`(("boost" ,boost)))
- ;; FIXME: Not needed any more for newer version 0.1.1.
- (arguments
- ;; avoid triggering a build failure due to warnings
- `(#:configure-flags '("--disable-werror")))
(home-page "https://wiki.documentfoundation.org/DLP/Libraries/libvisio")
(synopsis "Library for parsing the Microsoft Visio format")
(description "Libvisio is a library that parses the file format of