summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-08 18:58:03 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 18:38:00 +0200
commitc6234e8ac881b7d60441811fe54866b8fe4cad4a (patch)
tree6e07b65b3b80d5821c1a937760c57493b012105a /gnu/packages/libreoffice.scm
parent603231c1c32d3dda52c564a02559fabc558486b4 (diff)
downloadguix-patches-c6234e8ac881b7d60441811fe54866b8fe4cad4a.tar
guix-patches-c6234e8ac881b7d60441811fe54866b8fe4cad4a.tar.gz
gnu: libetonyek: Fix FTBFS with later liblangtag.
* gnu/packages/libreoffice.scm (libetonyek)[source]: Add upstream patch.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 0eb4ffb493..5c44fb31e1 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -363,7 +364,19 @@ CorelDRAW documents of all versions.")
name "-" version ".tar.xz"))
(sha256 (base32
"0y60vi1plyq69fqbcjnc0v8mvcjqjsl1ry6rmb3bq3q7j8a2fm6z"))
- (patches (search-patches "libetonyek-build-with-mdds-1.2.patch"))))
+ (patches
+ (cons
+ (origin
+ (method url-fetch)
+ ;; Drop incorrect test that fails with latest liblangtag.
+ (uri (string-append "https://cgit.freedesktop.org/libreoffice"
+ "/libetonyek/patch/?id="
+ "1a20d8ece2ea3e8aa1d319cd88e8a6aa637982f2"))
+ (file-name "libetonyek-build-with-liblangtag-0.6.patch")
+ (sha256
+ (base32
+ "0zdyykg3cmq226m54yjhg1fj5200c371h2qgjfna62dxa1jd6m97")))
+ (search-patches "libetonyek-build-with-mdds-1.2.patch")))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-mdds=1.2")