summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-03-27 20:16:32 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-03-27 20:16:32 +0200
commitb85b56dd7bb0185059e81f2aeeb0749e180d2084 (patch)
tree77c9699ae9c8d47ddb7c4ec184c6aabe1e3f5139 /gnu/packages/libreoffice.scm
parent22e52dbd06726261e370e9b761e7f3a3f6b47630 (diff)
downloadguix-patches-b85b56dd7bb0185059e81f2aeeb0749e180d2084.tar
guix-patches-b85b56dd7bb0185059e81f2aeeb0749e180d2084.tar.gz
gnu: libetonyek: Update to 0.1.6.
* gnu/packages/libreoffice.scm (libetonyek): Update to 0.1.6. [arguments]: Add phase 'autoreconf, because configure.ac is patched. Add configure flag "--with-mdds=1.2". [inputs]: Add liblangtag. [native-inputs]: Add autoconf and automake. * gnu/packages/patches/libetonyek-build-with-mdds-1.2.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a558d8e19e..3d056031ce 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -349,22 +349,31 @@ CorelDRAW documents of all versions.")
(define-public libetonyek
(package
(name "libetonyek")
- (version "0.1.3")
+ (version "0.1.6")
(source
(origin
(method url-fetch)
(uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256 (base32
- "0mghaqzj0qqza8z1gzprw62702adlww4kgdzynj5qpxxc9m2f4py"))))
+ "0y60vi1plyq69fqbcjnc0v8mvcjqjsl1ry6rmb3bq3q7j8a2fm6z"))
+ (patches (search-patches "libetonyek-build-with-mdds-1.2.patch"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--with-mdds=1.2")
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'autoreconf
+ (lambda _ (system* "autoreconf"))))))
(native-inputs
`(("cppunit" ,cppunit)
("doxygen" ,doxygen)
("glm" ,glm)
("gperf" ,gperf)
+ ("liblangtag" ,liblangtag)
("mdds" ,mdds)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf) ; due to patch
+ ("automake" ,automake)))
(propagated-inputs ; in Requires or Requires.private field of .pkg
`(("librevenge" ,librevenge)
("libxml2" ,libxml2)))