summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-03-07 12:42:02 +0200
committerAndreas Enge <andreas@enge.fr>2016-03-09 14:27:19 +0100
commit00eb9fa3e23fa692db163c3eae2a3269756c7e75 (patch)
tree1696b3a419ac2d9d53efabb00a89f0bbe4351f3e /gnu/packages/libreoffice.scm
parentebc816311c2c001dcd48c8ec9e88c3c84234c330 (diff)
downloadguix-patches-00eb9fa3e23fa692db163c3eae2a3269756c7e75.tar
guix-patches-00eb9fa3e23fa692db163c3eae2a3269756c7e75.tar.gz
gnu: Add liblangtag.
* gnu/packages/libreoffice.scm (liblangtag): New variable. Co-authored-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm32
1 files changed, 30 insertions, 2 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 7366c99e4c..9d58a267b6 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,7 +22,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module ((guix licenses)
- #:select (gpl2+ lgpl2.1+ mpl1.1 mpl2.0
+ #:select (gpl2+ lgpl2.1+ lgpl3+ mpl1.1 mpl2.0
non-copyleft x11-style))
#:use-module (guix packages)
#:use-module (guix utils)
@@ -373,6 +374,33 @@ CorelDRAW documents of all versions.")
Apple Keynote documents. It currently supports Keynote versions 2 to 5.")
(license mpl2.0)))
+(define-public liblangtag
+ (package
+ (name "liblangtag")
+ (version "0.5.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/tagoh/liblangtag/downloads/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1akf0d7yp29pv3j2pw2riii4n5kyjr9szc0y77khnx9zzr5zdqh8"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxml2" ,libxml2)))
+ (home-page "http://tagoh.bitbucket.org/liblangtag/")
+ (synopsis "Library to access tags for identifying languages")
+ (description "Liblangtag implements an interface to work with tags
+for identifying languages as described in RFC 5646. It supports the
+extensions described in RFC6067 and RFC6497, and Extension T for
+language/locale identifiers as described in the Unicode CLDR
+standard 21.0.2.")
+ (license (list lgpl3+ mpl2.0)))) ; dual license
+
(define-public libexttextcat
(package
(name "libexttextcat")