summaryrefslogtreecommitdiff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-16 23:18:23 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-17 13:03:50 -0500
commit4812a813a272261385d34d432cd1f2c46d403704 (patch)
tree5f6f4cec20518b9f93b932f6237bdeac6c5ba3ff /gnu/packages/language.scm
parent57ff0e04f18a253604a65d1e20128de2dff1dddd (diff)
downloadguix-patches-4812a813a272261385d34d432cd1f2c46d403704.tar
guix-patches-4812a813a272261385d34d432cd1f2c46d403704.tar.gz
gnu: Add Lingua-EN-Inflect-Number.
* gnu/packages/language.scm (perl-lingua-en-inflect-number): New variable.
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index c02771d12a..2fdffa0b72 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -67,6 +67,28 @@ provided. Where appropriate, \"classical\" variants (for example: \"brother\"
-> \"brethren\", \"dogma\" -> \"dogmata\", etc.) are also provided.")
(license (package-license perl))))
+(define-public perl-lingua-en-inflect-number
+ (package
+ (name "perl-lingua-en-inflect-number")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/N/NE/NEILB/"
+ "Lingua-EN-Inflect-Number-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rvgrff96ja7fqr79dszmiyv2wz4izw82znah0mx9szkir657gfz"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-lingua-en-inflect" ,perl-lingua-en-inflect)))
+ (home-page "http://search.cpan.org/dist/Lingua-EN-Inflect-Number")
+ (synopsis "Force number of words to singular or plural")
+ (description "This module extends the functionality of Lingua::EN::Inflect
+with three new functions for determining plurality of a word and forcefully
+converting a word to singular or plural.")
+ (license (package-license perl))))
+
(define-public perl-lingua-en-words2nums
(package
(name "perl-lingua-en-words2nums")