summaryrefslogtreecommitdiff
path: root/gnu/packages/kodi.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
commit154d97abdd16674fdebc763351f661bbcdc869a4 (patch)
tree0277a9380edd1390f16e432283d32499ffed36d1 /gnu/packages/kodi.scm
parente4696c69d75f4fcf54c42beeb928032726bdaf7d (diff)
parent87e7faa2ae641d8302efc8b90f1e45f43f67f6da (diff)
downloadguix-patches-154d97abdd16674fdebc763351f661bbcdc869a4.tar
guix-patches-154d97abdd16674fdebc763351f661bbcdc869a4.tar.gz
Merge remote-tracking branch master into core-updates
Diffstat (limited to 'gnu/packages/kodi.scm')
-rw-r--r--gnu/packages/kodi.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index 0e032d05db..59ea11f812 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -104,14 +104,12 @@
(replace 'build
(lambda _
(invoke "g++" "-c" "guid.cpp" "-o" "guid.o"
- "-std=c++11" "-DGUID_LIBUUID")
+ "-DGUID_LIBUUID")
(invoke "ar" "rvs" "libcrossguid.a" "guid.o")))
(replace 'check
(lambda _
- (invoke "g++" "-c" "test.cpp" "-o" "test.o"
- "-std=c++11")
- (invoke "g++" "-c" "testmain.cpp" "-o" "testmain.o"
- "-std=c++11")
+ (invoke "g++" "-c" "test.cpp" "-o" "test.o")
+ (invoke "g++" "-c" "testmain.cpp" "-o" "testmain.o")
(invoke "g++" "test.o" "guid.o" "testmain.o"
"-o" "test" "-luuid")
(invoke (string-append (getcwd) "/test"))))
@@ -282,6 +280,7 @@ alternatives. In compilers, this can reduce the cascade of secondary errors.")
(base32
"1m0295czxabdcqyqf5m94av9d88pzhnzjvyfs1q07xqq82h313p7"))
(patches (search-patches "kodi-skip-test-449.patch"
+ "kodi-increase-test-timeout.patch"
"kodi-set-libcurl-ssl-parameters.patch"))
(snippet
'(begin