summaryrefslogtreecommitdiff
path: root/gnu/packages/kerberos.scm
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-04-10 21:23:13 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-11 11:40:16 -0400
commit5480ba2491c6f2c84f88e45f47a5ec7348c07e3a (patch)
tree246ce540f0f4b1337034c9b6c49cc3b85c2e0e63 /gnu/packages/kerberos.scm
parent691f17a8cc6ba1c353ee65b41567e607ed3fcfae (diff)
downloadguix-patches-5480ba2491c6f2c84f88e45f47a5ec7348c07e3a.tar
guix-patches-5480ba2491c6f2c84f88e45f47a5ec7348c07e3a.tar.gz
gnu: heimdal: Enable OpenLDAP support.
* gnu/packages/kerberos.scm (heimdal) [native-inputs]: Add bison, flex and pkg-config. [inputs]: Remove mit-krb5. Add libcap-ng and openldap. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/kerberos.scm')
-rw-r--r--gnu/packages/kerberos.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index 2035f16d71..9e2f6acd56 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -30,10 +30,12 @@
(define-module (gnu packages kerberos)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages gettext)
@@ -41,6 +43,7 @@
#:use-module (gnu packages libidn)
#:use-module (gnu packages hurd)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages openldap)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages compression)
#:use-module (gnu packages readline)
@@ -249,15 +252,19 @@ After installation, the system administrator should generate keys using
(format #t "#!~a~%exit 1~%" (which "sh")))))))
;; Tests fail when run in parallel.
#:parallel-tests? #f))
- (native-inputs (list e2fsprogs ;for 'compile_et'
+ (native-inputs (list bison
+ e2fsprogs ;for 'compile_et'
+ flex
texinfo
- unzip ;for tests
+ unzip ;for tests
+ pkg-config
python))
(inputs (list readline
bash-minimal
bdb
- e2fsprogs ;for libcom_err
- mit-krb5
+ e2fsprogs ;for libcom_err
+ libcap-ng
+ openldap
sqlite))
(home-page "http://www.h5l.org/")
(synopsis "Kerberos 5 network authentication")