summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2020-12-25 20:06:53 +0800
committerEfraim Flashner <efraim@flashner.co.il>2021-01-05 19:54:40 +0200
commit31651ff6cd2ffdd008c9fc92ea17caa9df137848 (patch)
treee204081ec30ebfed5fbd67c6551d9e9b4e253dfd /gnu/packages/kde.scm
parent957f0c40327ce00f53db22737e3775ce616ac258 (diff)
downloadguix-patches-31651ff6cd2ffdd008c9fc92ea17caa9df137848.tar
guix-patches-31651ff6cd2ffdd008c9fc92ea17caa9df137848.tar.gz
gnu: Add akregator.
* gnu/packages/kde.scm (akregator): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 999633d78c..12d54a0b5d 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages djvu)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages ebook)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
@@ -141,6 +142,77 @@ This package contains GUI widgets for baloo.")
(license ;; LGPL for libraries, FDL for documentation
(list license:lgpl2.1+ license:fdl1.2+))))
+(define-public akregator
+ (package
+ (name "akregator")
+ (version "20.04.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/akregator-" version ".tar.xz"))
+ (sha256
+ (base32 "1711yhwsdq9iyc3wm3a4xmz81p73hvvc0h58sasc89ifpry50k2p"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-qt-process-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/akregator"))
+ (qt-process-path (string-append
+ (assoc-ref inputs "qtwebengine")
+ "/lib/qt5/libexec/QtWebEngineProcess")))
+ (wrap-program bin
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
+ #t))))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("akonadi" ,akonadi)
+ ("akonadi-contacts" ,akonadi-contacts)
+ ("akonadi-mime" ,akonadi-mime)
+ ("boost" ,boost)
+ ("breeze-icons" ,breeze-icons)
+ ("gpgme" ,gpgme)
+ ("grantlee" ,grantlee)
+ ("grantleetheme" ,grantleetheme)
+ ("kcmutils" ,kcmutils)
+ ("kcontacts" ,kcontacts)
+ ("kcrash" ,kcrash)
+ ("kimap" ,kimap)
+ ("kitemmodels" ,kitemmodels)
+ ("kmessagelib" ,kmessagelib)
+ ("kmime" ,kmime)
+ ("knotifications" ,knotifications)
+ ("knotifyconfig" ,knotifyconfig)
+ ("kontactinterface" ,kontactinterface)
+ ("kpimcommon" ,kpimcommon)
+ ("kpimtextedit" ,kpimtextedit)
+ ("kqtquickcharts" ,kqtquickcharts)
+ ("ktexteditor" ,ktexteditor)
+ ("kuserfeedback" ,kuserfeedback)
+ ("libkdepim" ,libkdepim)
+ ("libkleo" ,libkleo)
+ ("qgpgme" ,qgpgme)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebchannel" ,qtwebchannel)
+ ("qtwebengine" ,qtwebengine)
+ ("syndication" ,syndication)))
+ (home-page "https://apps.kde.org/en/akregator")
+ (synopsis "KDE Feed Reader")
+ (description
+ "Akregator is a news feed reader. It enables you to follow news
+sites, blogs and other RSS/Atom-enabled websites without the need to manually
+check for updates using a web browser. Akregator is designed to be both easy to
+use and to be powerful enough to read hundreds of news sources conveniently.
+It comes with a fast search, advanced archiving functionality and an internal
+browser for easy news reading.")
+ (license license:gpl2+)))
+
(define-public kdenlive
(let ((version "20.08.3"))
(package