summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2020-12-26 19:59:14 +0800
committerEfraim Flashner <efraim@flashner.co.il>2021-01-20 15:08:42 +0200
commite4ef47b229abb0e890dbaf272b1008234055c1cf (patch)
tree82e71f71791a2d99ef3746b8995453d9324657de /gnu/packages/kde.scm
parentb9cfa7ca862d3dfcb6241b61579c7cc059e30617 (diff)
downloadguix-patches-e4ef47b229abb0e890dbaf272b1008234055c1cf.tar
guix-patches-e4ef47b229abb0e890dbaf272b1008234055c1cf.tar.gz
gnu: Add kdf.
* gnu/packages/kde.scm (kdf): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 278e0d3882..2f321fc911 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -758,6 +758,40 @@ communicate with each other. Here's a few things KDE Connect can do:
charts.")
(license license:lgpl2.1+)))
+(define-public kdf
+ (package
+ (name "kdf")
+ (version "20.12.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/"
+ version "/src/kdf-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0ba67hs4vlb3qyvdzhnpmf8p62df12s8aqw4hzf9vnxff3qix5k1"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcmutils" ,kcmutils)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("knotifications" ,knotifications)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("qtbase" ,qtbase)))
+ (home-page "https://kde.org/applications/system/kdk")
+ (synopsis "View Disk Usage")
+ (description "KDiskFree displays the available file devices (hard drive
+partitions, floppy and CD drives, etc.) along with information on their
+capacity, free space, type and mount point. It also allows you to mount and
+unmount drives and view them in a file manager.")
+ (license license:gpl2+)))
+
(define-public kcachegrind
(package
(name "kcachegrind")