summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-28 23:09:53 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:09 +0100
commitdd2ba1a807378de4050d49904c377d66e3e42f0d (patch)
tree93796549dfb671ce81fe5b9e45a337b118c8cdf1 /gnu/packages/kde.scm
parent263280fd64ef88522ac2cefdd3a2cbd5570c9f48 (diff)
downloadguix-patches-dd2ba1a807378de4050d49904c377d66e3e42f0d.tar
guix-patches-dd2ba1a807378de4050d49904c377d66e3e42f0d.tar.gz
gnu: Add kio-fuse.
* gnu/packages/kde.scm (kio-fuse): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index fe76366b65..439a4b53f0 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -487,6 +487,34 @@ illustrate project schedules.")
the functionality of the KDE resource and network access abstractions.")
(license license:lgpl2.0+)))
+(define-public kio-fuse
+ (package
+ (name "kio-fuse")
+ (version "5.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/" name "/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1pb62h45c06dq3rml91xbf8j5y2c1l8z8j8lycchxrlgys5rlrv6"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" (getcwd))
+ (setenv "XDG_RUNTIME_DIR" (getcwd))
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (invoke "dbus-launch" "ctest" "-E"
+ "(fileopstest-cache|fileopstest-filejob)")))))))
+ (native-inputs (list dbus extra-cmake-modules pkg-config))
+ (inputs (list fuse-3 kio kcoreaddons qtbase-5))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "FUSE Interface for KIO")
+ (description "This package provides FUSE Interface for KIO.")
+ (license license:lgpl2.1+)))
(define-public kseexpr
(package