summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-15 17:11:22 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:42 +0800
commitbbf7c10e5dddb991197c2095362d24c1543b2404 (patch)
tree0d87420d9ef6b967df9643fb32c513583d558995 /gnu/packages/kde-plasma.scm
parentf370b61078dd0863631433f43d229196d5dc86a7 (diff)
downloadguix-patches-bbf7c10e5dddb991197c2095362d24c1543b2404.tar
guix-patches-bbf7c10e5dddb991197c2095362d24c1543b2404.tar.gz
gnu: kscreenlocker: Update to 5.27.6.
* gnu/packages/kde-plasma.scm (kscreenlocker): Update to 5.27.6. [inputs]: Add kio, libkscreen. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index d3c0c048e9..9062fc7911 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -825,14 +825,14 @@ an elegant and intuitive experience for your tasks and plasmoids.")
(define-public kscreenlocker
(package
(name "kscreenlocker")
- (version "5.25.5")
+ (version "5.27.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version
"/kscreenlocker-" version ".tar.xz"))
(sha256
(base32
- "0mivx0l266310iy52qi94b6wi8w2a8nl7cjn5750x66dz81jl3yj"))))
+ "0pgmy4dw41kim7syk4xb2n4g4iz3jjikhwnh3bjianl9h87rc12x"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f ;; TODO: make tests pass
@@ -863,6 +863,7 @@ an elegant and intuitive experience for your tasks and plasmoids.")
kdeclarative
kglobalaccel
ki18n
+ kio
kidletime
knotifications
ktextwidgets
@@ -870,6 +871,7 @@ an elegant and intuitive experience for your tasks and plasmoids.")
kwindowsystem
kxmlgui
layer-shell-qt
+ libkscreen
libseccomp ;for sandboxing the look'n'feel package
libxcursor ;missing in CMakeList.txt
libxi ;XInput, required for grabbing XInput2 devices