summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-29 22:21:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-03 18:05:13 -0400
commit2d613a1e8d60af628898aa0d153fa855d9376b10 (patch)
tree3d4bc53af2f0a0fa0e16fc86aaca149a6792a0e5 /gnu/packages/kde-frameworks.scm
parentca92295971f325d8fb4afe75ce1e1d6d0faeb614 (diff)
downloadguix-patches-2d613a1e8d60af628898aa0d153fa855d9376b10.tar
guix-patches-2d613a1e8d60af628898aa0d153fa855d9376b10.tar.gz
gnu: kwayland: Disable kwayland-testXdgForeign test.
* gnu/packages/kde-frameworks.scm (kwayland) [phases] <check>: Disable kwayland-testXdgForeign test. Change-Id: I302cd80031e288ac3a155935c2fe35c009194859
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 882cf40e26..321865b347 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1160,9 +1160,17 @@ protocols used in KDE Plasma.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "ctest" "-E"
- ;; XXX: maybe is upstream bug
- "(kwayland-testWaylandRegistry|\
-kwayland-testPlasmaShell|kwayland-testPlasmaWindowModel)")))))))
+ (string-append
+ "("
+ (string-join
+ ;; XXX: maybe is upstream bug
+ '("kwayland-testWaylandRegistry"
+ "kwayland-testPlasmaShell"
+ "kwayland-testPlasmaWindowModel"
+ ;; The 'kwayland-testXdgForeign' may fail on
+ ;; powerpc64le with a 'Subprocess aborted' error.
+ "kwayland-testXdgForeign") "|")
+ ")"))))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Qt-style API to interact with the wayland client and server")
(description "As the names suggest they implement a Client respectively a