summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:10:14 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:19 +0200
commit4d92ceb56816b003fc451b387bf06a81fa33f83c (patch)
tree2356a3c1690a937f9ccc2f7cf627a63a0cc5962d /gnu/packages/kde-frameworks.scm
parent13094df1edcf41428d253ced1f63a894e43e3ddb (diff)
downloadguix-patches-4d92ceb56816b003fc451b387bf06a81fa33f83c.tar
guix-patches-4d92ceb56816b003fc451b387bf06a81fa33f83c.tar.gz
gnu: Add kcrash.
* gnu/packages/kde-frameworks.scm (kcrash): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 572edb87cc..6fc0c85010 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1105,3 +1105,41 @@ utilities.")
applications. It provides a set of completion-ready widgets, or can be
integrated it into your application's other widgets.")
(license license:lgpl2.1+)))
+
+(define-public kcrash
+ (package
+ (name "kcrash")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1lahgfwlp9b5rsl244kzp7rsl4ybv1q4qlvpv0xxz5ygssk48l0w"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("xorg-server" ,xorg-server)))
+ (inputs
+ `(("kcoreaddons" ,kcoreaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system (string-append (assoc-ref inputs "xorg-server")
+ "/bin/Xvfb :1 &"))
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Graceful handling of application crashes")
+ (description "KCrash provides support for intercepting and handling
+application crashes.")
+ (license license:lgpl2.1+)))