summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-24 23:58:52 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:11:09 +0100
commitc1265fcc7090eccef32fdc8d5e38b4f596108e09 (patch)
tree59be00b3241a063874896b319870a326b0a57c3b /gnu/packages/kde-frameworks.scm
parent7feff6f6dc66b6b51d32568e11d3b383fa7a0dde (diff)
downloadguix-patches-c1265fcc7090eccef32fdc8d5e38b4f596108e09.tar
guix-patches-c1265fcc7090eccef32fdc8d5e38b4f596108e09.tar.gz
gnu: Add ksyntaxhighlighting.
* gnu/packages/kde-frameworks.scm (ksyntaxhighlighting): New variable.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index a4956e1738..c67d0c393f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -804,6 +804,57 @@ data being plotted. KPlotWidget automatically converts everything to screen
pixel units.")
(license license:lgpl2.1+)))
+(define-public ksyntaxhighlighting
+ (package
+ (name "ksyntaxhighlighting")
+ (version "5.28.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ "syntax-highlighting-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0gf1ldlk4gav6bg5b1231hphaal4simyngirvr1yizcb1rrlygdy"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("perl" ,perl)
+ ;; Optional, for compile-time validation of syntax definition files:
+ ("qtxmlpatterns" ,qtxmlpatterns)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'unpatch-source-shebang
+ (lambda _
+ ;; revert the patch-shebang phase on scripts which are
+ ;; in fact test data
+ (substitute* '("autotests/input/test.bash"
+ "autotests/folding/test.bash.fold")
+ (((which "bash")) "/bin/bash"))
+ (substitute* '("autotests/input/highlight.sh"
+ "autotests/folding/highlight.sh.fold")
+ (((which "sh")) " /bin/sh")) ;; space in front!
+ (substitute* '("autotests/input/highlight.pl"
+ "autotests/folding/highlight.pl.fold")
+ (((which "perl")) "/usr/bin/perl"))
+ #t))
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; enable debug info
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Syntax highlighting engine for Kate syntax definitions")
+ (description "This is a stand-alone implementation of the Kate syntax
+highlighting engine. It's meant as a building block for text editors as well
+as for simple highlighted text rendering (e.g. as HTML), supporting both
+integration with a custom editor as well as a ready-to-use
+@code{QSyntaxHighlighter} sub-class.")
+ (license license:lgpl2.1+)))
+
(define-public kwayland
(package
(name "kwayland")